groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remi Forax <fo...@univ-mlv.fr>
Subject Re: build requirements for Groovy and language level in master
Date Sun, 09 Apr 2017 09:09:49 GMT


On April 8, 2017 7:35:18 PM GMT+02:00, Jochen Theodorou <blackdrag@gmx.org> wrote:
>On 08.04.2017 16:29, Remi Forax wrote:
>> Jochen,
>> technically, you do not need the jdk 9,
>> you can compile with jdk 8 and have a jar that contains the
>declaration
>> of methods of the jdk 9 you want.
>
>and use -Xbootclasspath/p:path? yes, I guess we can do that.
>JDK-8177827 
>will get in the way, but that is minor. Too bad that is in the future
>no 
>real option anymore because of JDK-8177844. 

you can use --patch-module, 8177844 is about --patch-module having the side effect of making
the module upgradeable,  i.e. being able to replace the module instead of patching it.

> But that will not affect us right now
>
>> JRuby had worked that way when it was jdk 6 compatible but optionally
>> uses the java.lang.invoke API.
>
>yeah, good idea ;)
>
>bye Jochen

RĂ©mi 

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

Mime
View raw message