groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graeme Rocher <graeme.roc...@gmail.com>
Subject Re: [VOTE] Apache Groovy Roadmap
Date Tue, 31 Jan 2017 13:35:31 GMT
YES from me.

IMO we should not be waiting until 3.x for Parrot however, I am also
ok with the proposal to change the roadmap so that Groovy 3.x is the
Parrot release and Groovy 4.x the breaking Jigsaw/Java 8/9 release.

The sooner we get folks testing Parrot in the real world the better
and if we wait more it will be a very long time before we see Parrot
or any of the new features used in a project.

Cheers

On Tue, Jan 31, 2017 at 1:46 PM, Sven Reimers <sven.reimers@gmail.com> wrote:
> I would be volunteering for checking if this is a problem in NetBeans Groovy
> Support. What are the patterns I should look for?
>
> Already any branch I could build and try as an experiment?
>
> Thanks
>
> Sven
>
> Am 31.01.2017 12:46 schrieb "Jochen Theodorou" <blackdrag@gmx.org>:
>>
>> [..]
>>>
>>> Were exactly was this leak? The antlr2 classes are jarjar'ed, right -
>>> they were hardly API. Or am I missing something?
>>> As for usage: A quick search on GitHub for the string
>>> 'groovyjarjarantlr' revealed 12 commits, most of them in Adempiere and
>>> 'groovy-class-parser', in pretty old code.
>>
>>
>> I am thinking for example of the groovy-eclipse plugin. Also we do not
>> catch all exceptions thrown by antlr afaik.
>>
>> But maybe I overestimate the problem
>>
>> bye Jochen



-- 
Graeme Rocher

Mime
View raw message