groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul King <pa...@asert.com.au>
Subject Re: [VOTE] Release Groovy 2.4.8
Date Mon, 02 Jan 2017 19:58:40 GMT
Well, it's designed so that we have any easy way to bootstrap from the
source distro for people who aren't familiar with gradle. No need to
know about any built-in commands or properties. We could get rid of it
but it would make the instructions slightly more verbose and of course
different between versions.

On Tue, Jan 3, 2017 at 5:49 AM, Keegan Witt <keeganwitt@gmail.com> wrote:
> It looks like it's there for the downloadWrapper task (wrapper.gradle).  But
> I'm not sure why we have that defined.  I've always just used
> gradle-wrapper.properties and "gradlew wrapper" to update the wrapper jar
> and gradlew scripts.  If we don't need it anymore, I say we remove both the
> property and wrapper.gradle.
>
> -Keegan
>
> On Sat, Dec 31, 2016 at 7:29 AM, Paul King <paulk@asert.com.au> wrote:
>>
>> I imagine some of them could be moved but I think what we have is the
>> more common place to have those versions.
>> I am unsure whether an IDE assistance would be affected with such a
>> move - I haven't actually tried.
>>
>> Cheers, Paul.
>>
>> On Sat, Dec 31, 2016 at 9:57 PM, Jochen Theodorou <blackdrag@gmx.org>
>> wrote:
>> > On 31.12.2016 12:38, Paul King wrote:
>> > [...]
>> >>
>> >> There is a 'gradleVersion' property (set in the build.gradle file)
>> >> which is used when bootstrapping the wrapper, so no need for further
>> >> instructions in that regard.
>> >
>> >
>> > ah, ok. I am used to find those things in gradle.properties now... Is
>> > there
>> > any reason we cannot transfer all those properties in that ext block
>> > there?
>> >
>> > bye Jochen
>> >
>
>

Mime
View raw message