groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Wagenleitner <john.wagenleit...@gmail.com>
Subject Re: [VOTE] Release Groovy 2.4.8
Date Tue, 10 Jan 2017 04:22:16 GMT
With the downloaded source I was using gradle 2.14.  I also fetched the
GROOVY_2_4_8 tag and ran gradlew from there which is 2.3.  I get the error
with both.  Not sure if I need to set up a property to point to gpg keys,
but haven't had to do that in the past.

On Mon, Jan 9, 2017 at 7:42 PM, Paul King <paulk@asert.com.au> wrote:

> Can you check the version of gradle that is running? The artifacts are
> built using install and install works fine for me from the src zip.
>
> On Tue, Jan 10, 2017 at 12:33 PM, John Wagenleitner
> <john.wagenleitner@gmail.com> wrote:
> > When I run `gradlew install` from source (both from the downloaded zip
> and
> > from the GROOVY_2_4_8 tag) I get the error below.  Looks like prior to
> > commit 9fa4b015e4a80ef03 [1] this was a warning but now it fails the
> build
> > and wont install the artifacts in the local maven repo.
> >
> > [1]
> > https://github.com/apache/groovy/commit/9fa4b015e4a80ef036ef32aa48158f
> 8360663000
> >
> > -------------------------------------------
> > :groovy-groovydoc:javadoc
> > :groovy-ant:javadoc
> > /ASF/groovy/subprojects/groovy-ant/src/main/java/org/
> codehaus/groovy/ant/Groovyc.java:42:
> > error: cannot find symbol
> > import org.apache.commons.cli.GroovyInternalPosixParser;
> >                              ^
> >   symbol:   class GroovyInternalPosixParser
> >   location: package org.apache.commons.cli
> > 1 warning
> > :groovy-ant:javadocJar
> > :groovy-ant:install FAILED
> >
> > FAILURE: Build failed with an exception.
> >
> > * What went wrong:
> > Execution failed for task ':groovy-ant:install'.
> >> Could not publish configuration 'archives'
> >    > Cannot publish artifact 'groovy-ant.jar.asc
> > (org.codehaus.groovy:groovy-ant:2.4.8)'
> > (/ASF/groovy/subprojects/groovy-ant/target/libs/groovy-ant-2.4.8.jar.asc)
> as
> > it does not exist.
> >
> > * Try:
> > Run with --stacktrace option to get the stack trace. Run with --info or
> > --debug option to get more log output.
> >
> > BUILD FAILED
> > -------------------------------------------
> >
> >
> > On Sun, Jan 8, 2017 at 10:33 PM, Paul King <paulk@asert.com.au> wrote:
> >>
> >> Dear community,
> >>
> >> I am happy to start the VOTE thread for a Groovy 2.4.8 release!
> >>
> >> This release includes 84 bug fixes/improvements as outlined in the
> >> changelog:
> >>
> >> https://issues.apache.org/jira/secure/ReleaseNote.jspa?
> projectId=12318123&version=12335950
> >>
> >> Tag:
> >> https://git1-us-west.apache.org/repos/asf?p=groovy.git;a=
> tag;h=refs/tags/GROOVY_2_4_8
> >> Tag commit id: a1dc0fabb39feb2410d00c7919965557c7841ed6
> >>
> >> The artifacts to be voted on are located as follows (r17713).
> >> Source release:
> >> https://dist.apache.org/repos/dist/dev/groovy/2.4.8/sources
> >> Convenience binaries:
> >> https://dist.apache.org/repos/dist/dev/groovy/2.4.8/distribution
> >>
> >> Release artifacts are signed with a key from the following file:
> >> https://dist.apache.org/repos/dist/dev/groovy/KEYS
> >>
> >> Please vote on releasing this package as Apache Groovy 2.4.8.
> >>
> >> The vote is open for the next 72 hours and passes if a majority of at
> >> least three +1 PMC votes are cast.
> >>
> >> [ ] +1 Release Apache Groovy 2.4.8
> >> [ ]  0 I don't have a strong opinion about this, but I assume it's ok
> >> [ ] -1 Do not release Apache Groovy 2.4.8 because...
> >>
> >> Here is my vote:
> >>
> >> +1 (binding)
> >
> >
>

Mime
View raw message