groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cédric Champeau <cedric.champ...@gmail.com>
Subject Re: release process
Date Tue, 24 Jan 2017 17:08:01 GMT
2017-01-24 16:59 GMT+01:00 Jochen Theodorou <blackdrag@gmx.org>:

>
>
> On 24.01.2017 15:51, Cédric Champeau wrote:
>
>> The main problem is parrot is that it requires Java 8, and 2.5 is
>> planned to support 1.7. And bundling such a core thing as an
>> experimental, optional module is a no-go for me (imagine the bug
>> reports...). We could have a 2.9 release (or something similar) with
>> Parrot sooner, though.
>>
>> (as a side note, any release of Groovy that would require Java 8 would
>> be a no-go for Gradle in short term, be it 2.x or 3.x)
>>
>
> you misunderstand one essential part here. The parrot module would require
> java8, building Groovy would require Java8, executing Groovy would not
> require Java8 as long as parrot is not used.


I do understand this. But we're talking about a parser. Not an extension
module that is technically optional. A parser is not optional, it's
critical part of the compilation process, and if a user goes with parrot,
he doesn't go with the legacy one, and it can produce different outputs.
This is very different from an optional module that is used, or not used.
And, again, it would increase the size of the distribution, while 99% of
users wouldn't care.

Mime
View raw message