groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From C├ędric Champeau <cedric.champ...@gmail.com>
Subject Re: next releases
Date Tue, 17 Jan 2017 08:54:31 GMT
I'm reluctant on adding the experimental parser in a release. It requires a
different version of antlr, which means more dependencies than we really
need. We should keep the distribution as clean as possible. Not saying that
the new parser is dirty, but that the size and dependencies of the
distribution should remain as small as possible.

2017-01-17 9:48 GMT+01:00 Daniel Sun <realbluesun@hotmail.com>:

> Hi Paul,
>
>       Will the new parser Parrot be included in 2.5.x releases as an
> optional parser? If developers want to give it a try, just turn on the
> switch "-Dgroovy.antlr4=true".
>
> Cheers,
> Daniel.Sun
>
>
>
> --
> View this message in context: http://groovy.329449.n5.
> nabble.com/next-releases-tp5737758p5737761.html
> Sent from the Groovy Dev mailing list archive at Nabble.com.
>

Mime
View raw message