groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesper Steen Møller <>
Subject Re: release process
Date Tue, 24 Jan 2017 19:49:54 GMT
But - I recognise that the Antlr4 parser AST building looks really neat in Java 8, but easthetics
aside, wouldn’t it we a relatively easy task to port back to Java 7?


> On 24 Jan 2017, at 16.59, Jochen Theodorou <> wrote:
> On 24.01.2017 15:51, Cédric Champeau wrote:
>> The main problem is parrot is that it requires Java 8, and 2.5 is
>> planned to support 1.7. And bundling such a core thing as an
>> experimental, optional module is a no-go for me (imagine the bug
>> reports...). We could have a 2.9 release (or something similar) with
>> Parrot sooner, though.
>> (as a side note, any release of Groovy that would require Java 8 would
>> be a no-go for Gradle in short term, be it 2.x or 3.x)
> you misunderstand one essential part here. The parrot module would require java8, building
Groovy would require Java8, executing Groovy would not require Java8 as long as parrot is
not used. We have often parts of Groovy that require a higher version than the minimum one.
At a time we required java5, but had a module for java6. Same for java7. Had we go with some
proposals we would also have a java8 part while still requiring java7 as minimal version for
> bye Jochen

View raw message