groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jochen Theodorou <blackd...@gmx.org>
Subject Re: [VOTE] Release Groovy 2.4.8
Date Sat, 31 Dec 2016 09:45:27 GMT
Is it maybe because Groovy 2.4.8 is supposed to use Gradle 2.3 and that 
this build then does not work with Gradle 3.2.1, the version master is 
using?

Just tested, and yes, this seems to be the cause. This means you cannot 
create the wrapper using Gradle 3.2.1 because the build file is not 
compatible.

Besides that... where do we define the gradle version to be used for the 
build? If not any gradle version will work we need to specify that in 
the build instructions for the source distribution at least.

bye Jochen

On 31.12.2016 03:25, Paul King wrote:
> The README gives bootstrap instructions for building from source. In
> particular, you should not copy gradlew from another groovy install.
> Instead you can just run any gradle and that will effectively do a
> "gradle wrapper" which will get the correct gradle version. Let me
> know if that works.
>
> Cheers, Paul.
>
> On Sat, Dec 31, 2016 at 11:16 AM, Jochen Theodorou <blackdrag@gmx.org> wrote:
>> On 30.12.2016 22:13, Paul King wrote:
>>>
>>> Can you give some more info? I can't replicate.
>>
>>
>> I copied the 3.2.1 wrapper over and then tried to start... this is what I
>> got.
>> Just tried again using another 3.2.1 wrapper and this time I got
>>
>>> FAILURE: Build failed with an exception.
>>>
>>> * Where:
>>> Script '/tmp/r/groovy-2.4.8/gradle/docs.gradle' line: 63
>>>
>>> * What went wrong:
>>> A problem occurred evaluating script.
>>>>
>>>> Could not set unknown property 'overview' for task ':groovydoc' of type
>>>> org.gradle.api.tasks.javadoc.Groovydoc.
>>>
>>>
>>> * Try:
>>> Run with --stacktrace option to get the stack trace. Run with --info or
>>> --debug option to get more log output.
>>>
>>> BUILD FAILED
>>
>>
>> bye Jochen
>>


Mime
View raw message