groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Russel Winder <rus...@winder.org.uk>
Subject Re: Groovy Build
Date Sun, 18 Dec 2016 09:55:07 GMT
On Sun, 2016-12-11 at 10:51 +0100, Jochen Theodorou wrote:
> […]
> 
> does install install both? otherwise you can control it using -P 
> indy=true when using gradle

I have no idea, I really should find out. :-)
> 
> But in general... the non-indy build does contain indy, it just is
> not 
> build with indy. I doubt you will notice a big difference. You still 
> have to enable indy in both versions
> 

It is my intention in the new year to finish creating GPars 2.0, mostly
by just ripping out everything to do with ParallelArray, along with all
the APIs directly related to it, leaving just the dataflow, actor,
active object, agent, etc. stuff. I.e keep everything of GPars except
the bits that have been made redundant by Java Streams. 

GPars 2.0 will be JDK8 and later only, which seems fair enough as no-
one should really be using anything earlier, except on Android – and I
suspect no-one is using GPars on Android.

So my question behind the build question is which builds of Groovy
should I be testing GPars on, and is there a way of shipping a new
GPars 2.0 for Groovy on JDK8 and GPars 1.3 for Groovy on earlier JDKs.
 
-- 
Russel.
=============================================================================
Dr Russel Winder      t: +44 20 7585 2200   voip: sip:russel.winder@ekiga.net
41 Buckmaster Road    m: +44 7770 465 077   xmpp: russel@winder.org.uk
London SW11 1EN, UK   w: www.russel.org.uk  skype: russel_winder
Mime
View raw message