groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From daniel_sun <realblue...@hotmail.com>
Subject Re: getting in line for the releases of groovy 2.4.8 and 2.5.0-beta-1
Date Thu, 20 Oct 2016 13:15:09 GMT
Hi C├ędric,

      If possible, how about providing the new parser via putting it in a
separate artifact(e.g. groovy-parser-x.x.x.jar). When Groovy developers want
to try the new parser, they can enable the switch(-Dgroovy.antlr4=true).
Before set the new parser as the default parser in the future release, we
can get many feedback and make the new parser better and better :)

      Although there are 3 failing test cases related to macro, Sergei's
PR(https://github.com/apache/groovy/pull/443) can fix them. I wish the PR
could be reviewed and merged as soon as possible.

Cheers,
Daniel.Sun



--
View this message in context: http://groovy.329449.n5.nabble.com/getting-in-line-for-the-releases-of-groovy-2-4-8-and-2-5-0-beta-1-tp5736209p5736226.html
Sent from the Groovy Dev mailing list archive at Nabble.com.

Mime
View raw message