groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From C├ędric Champeau <cedric.champ...@gmail.com>
Subject Re: JDK version for Groovy
Date Thu, 07 Jul 2016 15:25:28 GMT
Gradle 3.0 will require JDK 7. Gradle 2.x can run on JDK 6. I'm not a big
fan of "backporting". To me it's easier to complete 2.5 with JDK 7 now,
then switch master to 3.0 and upgrade to JDK 8 there. One of the reasons I
would consider this decision touchy is that Gradle would then not be able
to migrate to Gradle 3, at least until Gradle 4.0. But, given the large
number of plugins written in Groovy today, upgrading would be a problem
anyway if Groovy 3 breaks binary compatibility.

2016-07-07 17:20 GMT+02:00 Guillaume Laforge <glaforge@gmail.com>:

> Do you know what are the latest requirements for Grails and Gradle?
> They're all on JDK 7+?
>
> On Thu, Jul 7, 2016 at 5:14 PM, Jochen Theodorou <blackdrag@gmx.org>
> wrote:
>
>> I really really would like to switch to JDK8 right away for many
>> reasons... but I think we need a JDK6 support story still. How about 2.5 in
>> JDK8, but with backport to JDK6?
>>
>> bye Jochen
>>
>
>
>
> --
> Guillaume Laforge
> Apache Groovy committer & PMC Vice-President
> Developer Advocate @ Google Cloud Platform
>
> Blog: http://glaforge.appspot.com/
> Social: @glaforge <http://twitter.com/glaforge> / Google+
> <https://plus.google.com/u/0/114130972232398734985/posts>
>

Mime
View raw message