groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pascal Schumacher <pascalschumac...@gmx.net>
Subject JDK 9 Indy Test Failures
Date Sun, 21 Feb 2016 15:12:59 GMT
Hello everybody,

since a few weeks the "normal" groovy build and tests pass on JDK9.

But when invoke-dynamic is used some groovy-sh tests fail:

http://ci.groovy-lang.org/viewLog.html?buildId=31836&tab=buildResultsDiv&buildTypeId=Groovy_Jdk9Build&guest=1

with:

java.lang.IncompatibleClassChangeError: Found class java.util.jar.JarFile$JarEntryIterator,
but interface was expected
     at org.codehaus.groovy.tools.shell.util.PackageHelperImpl.getPackageNamesFromJar(PackageHelperImpl.groovy:283)

As far as I understand this error normally occurs, when you have binary 
incompatible changes. But that should not be the case.

Any ideas why this error occurs and why it only occurs when using indy?

Cheers,
Pascal

Mime
View raw message