groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fernando Ariel Niwes Naufal <ferna...@soluciones3f.com.ar>
Subject Re: Adding map, reduce, filter as aliases for collect, inject, grep methods
Date Sun, 01 Nov 2015 15:20:27 GMT
As a developer, to have many names for the same operations is confusing. I
always doubt if there is a slight difference or not, also makes harder to
read code written by another person, as they can chose to use the variant
that I am not used to.

Also, as usual developer of C# and Javascript, was not difficult to me to
learn the equivalence.

A clarification in the documentation about what's the name of the same
concept in other programming languages is, for me, more than enough.

On Sun, Nov 1, 2015 at 11:36 AM, Russel Winder <russel@winder.org.uk> wrote:

> On Sun, 2015-11-01 at 08:14 +0100, Pascal Schumacher wrote:
> > Hi everybody,
> >
> > what about adding the more common names of map/reduce/filter for the
> > Ruby inspired collect/inject/grep methods?
>
> Whilst it maybe that James and Bob picked the names from Ruby, Ruby got
> (at least most of) them from Smalltalk. So perhaps in the above
> s/Ruby/Smalltalk/.
>
> > Imho these names are more descriptive and would make it easier for
> > beginners.
> >
> > What do you think?
>
> This argument has been had many times before in the last 12 years.
> Invariable there are those who think yes and those who oppose. To date
> the opposers have won out, usually on the grounds of "why change?" and
> "breaks backward compatibility".
>
> You will note that GPars supports both names :-)
>
> --
> Russel.
>
> =============================================================================
> Dr Russel Winder      t: +44 20 7585 2200   voip:
> sip:russel.winder@ekiga.net
> 41 Buckmaster Road    m: +44 7770 465 077   xmpp: russel@winder.org.uk
> London SW11 1EN, UK   w: www.russel.org.uk  skype: russel_winder
>
>

Mime
View raw message