groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Suderman <>
Subject Re: Adding map, reduce, filter as aliases for collect, inject, grep methods
Date Sun, 01 Nov 2015 17:55:44 GMT

I prefer the names map/reduce/filter. However, as Russel pointed out, the other times this
has been brought up the “opposers” have prevailed with the argument that it is easy enough
for people to add these methods themselves with an extension modules [1] or with a simple
category class.  The few times I’ve wanted these methods I usually just go with a category



> On Nov 1, 2015, at 2:14 AM, Pascal Schumacher <> wrote:
> Hi everybody,
> what about adding the more common names of map/reduce/filter for the Ruby inspired collect/inject/grep
> Imho these names are more descriptive and would make it easier for beginners.
> What do you think?
> -Pascal

Research Associate
Department of Computer Science
Vassar College
Poughkeepsie, NY

View raw message