groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Russel Winder <>
Subject Re: Adding map, reduce, filter as aliases for collect, inject, grep methods
Date Sun, 01 Nov 2015 14:36:57 GMT
On Sun, 2015-11-01 at 08:14 +0100, Pascal Schumacher wrote:
> Hi everybody,
> what about adding the more common names of map/reduce/filter for the 
> Ruby inspired collect/inject/grep methods?

Whilst it maybe that James and Bob picked the names from Ruby, Ruby got
(at least most of) them from Smalltalk. So perhaps in the above

> Imho these names are more descriptive and would make it easier for 
> beginners.
> What do you think?

This argument has been had many times before in the last 12 years.
Invariable there are those who think yes and those who oppose. To date
the opposers have won out, usually on the grounds of "why change?" and
"breaks backward compatibility".

You will note that GPars supports both names :-)

Dr Russel Winder      t: +44 20 7585 2200   voip:
41 Buckmaster Road    m: +44 7770 465 077   xmpp:
London SW11 1EN, UK   w:  skype: russel_winder

View raw message