groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cédric Champeau <cedric.champ...@gmail.com>
Subject Re: [VOTE] Release Apache Groovy 2.4.4-incubating
Date Sat, 11 Jul 2015 06:28:01 GMT
2015-07-11 8:02 GMT+02:00 Emmanuel Lécharny <elecharny@gmail.com>:

> Binding : [X] +1 Release Apache Groovy 2.4.4-incubating
>
> Source package builded, tags GROOVY_2.4.4 builded, signature checked,
> all sounds good to me !
>
>
> A remark :
> When I build groovy (Mac OSX 10.9, Java 1.8.0_45, gradle 2.4.4), I see a
> few things like :
>
> [ant:groovydoc] line 775:13: expecting LCURLY, found '('
>
>     No idea if it's normal or not, just signaling it
>
>
> It is not normal, but a problem with our parser. But groovydoc is one of
the most difficult things to update...


>
> /Users/elecharny/Downloads/groovy-2.4.4/subprojects/groovy-json/src/main/java/groovy/json/internal/FastStringUtils.java:21:
> warning: Unsafe is internal proprietary API and may be removed in a
> future release
> import sun.misc.Unsafe;
>
>     I don't like Unsafe. It should never had leaked as a class...
>
> Unsafe is optional. If you have it, the JSON parser is much faster.

>
>
> Note:
>
> /Users/elecharny/Downloads/groovy-2.4.4/subprojects/groovy-console/src/main/groovy/groovy/ui/ConsoleTextEditor.java
> uses or overrides a deprecated API.
>
>
>     May be due to teh fact I built it with Java 8 ?
>
> Yes. And since we make sure we are compatible for Java 6+ we can't remove
all deprecations yet.

Mime
View raw message