groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cédric Champeau <cedric.champ...@gmail.com>
Subject Re: Regression in JDK 9?
Date Sun, 14 Jun 2015 14:55:23 GMT
Ok so if we make those changes to 2.4.x as well, then I would suggest to
upgrade the wrapper too, because they come as a whole : those changes are
directly related to JDK 9 support and not needed otherwise.

2015-06-14 8:34 GMT+02:00 Jochen Theodorou <blackdrag@gmx.org>:

> Am 13.06.2015 18:36, schrieb Cédric Champeau:
>
>> I am currently investigating building Groovy on the latest JDK 9 b66.
>> First of all, I am making the changes on master, which means that only
>> Groovy 2.5 will officially support JDK 9, does it sound ok for you guys?
>>
>> First of all, I had to change some signatures in DGM for the JDK 9
>> generics type checker to be happy. I think those changes make sense, and
>> probably the checker in previous versions of the JDK wasn't strict
>> enough:
>>
>> https://github.com/apache/incubator-groovy/commit/83d680877c44072c46bdf2212303398ac3b1276e
>>
>> I also changed the Gradle wrapper to use a snapshot version of Gradle
>> 2.6, which fixes JDK 9 compatibility. This is also only done on master.
>>
>
> If you mean that all changes but the gradle wrapper version update to a
> snapshot will also go to Groovy 2.4.x, then I am ok with this. But once
> there is an official Gradle release with that we should update Groovy 2.4.x
> as well.
>
>
> bye blackdrag
>
> --
> Jochen "blackdrag" Theodorou
> blog: http://blackdragsview.blogspot.com/
>
>

Mime
View raw message