groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cédric Champeau <cedric.champ...@gmail.com>
Subject Re: Update of headers
Date Sat, 04 Apr 2015 07:35:00 GMT
Right. So it's still unclear to me what is required. We have a lot of
dependencies, some are mandatory, some are optional and some are just build
time dependencies (Gradle, plugins, ...). The list can be found on the
proposal [1] page. I assume the file must say something like "X is licensed
under Y"? Or is it only dependencies included as source form that require
to be in the license file?

[1] https://wiki.apache.org/incubator/GroovyProposal

2015-04-04 1:26 GMT+02:00 Emmanuel Lécharny <elecharny@gmail.com>:

> Le 03/04/15 21:18, Cédric Champeau a écrit :
> > I have updated the license on master and 2.4.x. I think updating 2.3
> should
> > be only necessary if we ever release this maintenance branch again. If
> you
> > guys have some time to check at least master, would be nice (so that we
> > don't discover problems too late, during a release...).
> >
> > I have also a question regarding how we should update NOTICE [1] and
> > LICENSE [2]. Let me know what you think.
> >
> > [1] https://github.com/groovy/groovy-core/blob/master/NOTICE
> > [2] https://github.com/groovy/groovy-core/blob/master/LICENSE
>
> Have you any other dependency on any third party ? If so, their licenses
> should be added accordingly to their requirements.
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message