groovy-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jwagenleit...@apache.org
Subject [1/2] groovy git commit: require JDK 8+ for release builds
Date Sun, 28 May 2017 13:53:01 GMT
Repository: groovy
Updated Branches:
  refs/heads/GROOVY_2_5_X 039476ec2 -> 4c7bec0a8


require JDK 8+ for release builds

Related to change for GROOVY-7611 (PR #545), JDK 8+
is required in order to compile all features.


Project: http://git-wip-us.apache.org/repos/asf/groovy/repo
Commit: http://git-wip-us.apache.org/repos/asf/groovy/commit/c2fd0a01
Tree: http://git-wip-us.apache.org/repos/asf/groovy/tree/c2fd0a01
Diff: http://git-wip-us.apache.org/repos/asf/groovy/diff/c2fd0a01

Branch: refs/heads/GROOVY_2_5_X
Commit: c2fd0a01f044e651f7bb8ae70d52fa82b9c686aa
Parents: 039476e
Author: John Wagenleitner <jwagenleitner@apache.org>
Authored: Sat May 27 15:21:43 2017 -0700
Committer: John Wagenleitner <jwagenleitner@apache.org>
Committed: Sun May 28 06:43:22 2017 -0700

----------------------------------------------------------------------
 build.gradle | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/groovy/blob/c2fd0a01/build.gradle
----------------------------------------------------------------------
diff --git a/build.gradle b/build.gradle
index 63fedc7..51f64d0 100644
--- a/build.gradle
+++ b/build.gradle
@@ -470,18 +470,17 @@ compileTestGroovy {
     groovyOptions.fork(memoryMaximumSize: groovycTest_mx)
 }
 
-// TODO superfluous to check for JDK7 for Gradle version 3.2+ but leave for future?
 task checkCompatibility {
     doLast {
-        assert JavaVersion.current().java7Compatible
+        assert JavaVersion.current().isJava8Compatible()
     }
 }
 
-if (!JavaVersion.current().java7Compatible) {
+if (!JavaVersion.current().isJava8Compatible()) {
     logger.lifecycle '''
     **************************************** WARNING ********************************************
-    ******   You are running the build with an older JDK. NEVER try to release with 1.6.
  ******
-    ******   You must use a JDK 1.7+ in order to compile all features of the language.  
  ******
+    ******   You are running the build with an older JDK. NEVER try to release with 1.7.
  ******
+    ******   You must use a JDK 1.8+ in order to compile all features of the language.  
  ******
     *********************************************************************************************
 '''
 }


Mime
View raw message