You need only the last one. It works in 1.2.

Dne 13. 4. 2016 17:17 napsal uživatel "Mingtao Lei" <mingtaol@sfu.ca>:
There are three patches in giraph-886. Which patch should I apply or if I need to apply them one by one? Does it work on giraph-1.2.0?




----- Original Message -----
From: "lukas nalezenec" <lukas.nalezenec@gmail.com>
To: user@giraph.apache.org
Sent: Wednesday, 13 April, 2016 02:51:10
Subject: RE: Maybe a bug in PartitionBalancer.java

Hi,

I have already fixed that, patch is available. See ticket GIRAPH-886
<https://issues.apache.org/jira/browse/GIRAPH-886> . Apply the patch, test
it and then please contact some Giraph commiter to merge it.

Lukas



Hi there,

     We would like to change the balance algorithm. For example, we would
like change “STATIC_BALANCE_ALGORITHM” to “EDGE_BALANCE_ALGORITHM”. So, we
changed it at line 202. That was "String balanceAlgorithm =

conf.get(PARTITION_BALANCE_ALGORITHM, EGDE_BALANCE_ALGORITHM)”. But the job
filed. We thought it was a bug. Does anyone fix it or have a solution?


     Thank you.

     Bests,