giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Meena Rajani <meenakraj...@gmail.com>
Subject Re: error starting MRAppmaster caused by java.lang.ClassNotFoundException: org.apache.hadoop.conf.Configuration$DeprecationDelta
Date Fri, 20 Nov 2015 05:54:02 GMT
The SimpleShortestPathsComputation example worked after I build Giraph
with  mvn -Phadoop_2 -Dhadoop.version=2.5.1 -DskipTests compile -X
I tried with hadoop 2.20 and also tried changing pom by adding a profile
for hadoop 2.2.0 in that and then tried building graph. But I was getting
sasl/jetty error. So finally i treid compiling it with  hadoop 2.5.1
version and it worked.
mvn -Phadoop_2 -Dhadoop.version=2.5.1 -DskipTests compile -X

Thanks

Meena




On Thu, Nov 19, 2015 at 8:37 PM, Meena Rajani <meenakrajani@gmail.com>
wrote:

> Thanks. Okay I am going to make a new build of Giraph  for hadoop 2.2.
> Good idea. Let me see if that works.
>
> Do you have idea from where does hadoop take the class path. I have tried
> changing it at several places in .bashrc, yarn-site.xml, on linux terminal
> but it get overriden to something different. For example when i do
> yarn classpath hdfs/
> I am always getting /usr/share/hadoop/lib
>
> While I am trying to /usr/local/hadoop/share/hadoop/yarn/lib
>
> Thanks
>
> Meena
>
> On Thu, Nov 19, 2015 at 9:17 AM, Ritesh Kumar Singh <
> riteshoneinamillion@gmail.com> wrote:
>
>> I'm not sure about the exact issue, but you have hadoop version 2.2
>> installed, and you are trying to install giraph with Hadoop version 2.6 as
>> you have stated in this line :
>> mvn -Phadoop_yarn -Dhadoop.version=2.6.0
>>
>> Maybe try changing that first?
>>
>
>

Mime
View raw message