giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Kaeser <steve.kae...@gmail.com>
Subject error running Giraph using Hive on Hadoop2
Date Mon, 16 Nov 2015 01:20:10 GMT
Hi All,

I'm new to Giraph and I'm having some difficulties getting it to run with
Hive on Hadoop2.  This is the error message that I am getting:

Exception in thread "main" java.lang.IncompatibleClassChangeError: Found
interface org.apache.hadoop.mapreduce.JobContext, but class was expected
    at
org.apache.giraph.bsp.BspOutputFormat.checkOutputSpecs(BspOutputFormat.java:43)
    at
org.apache.hadoop.mapreduce.JobSubmitter.checkSpecs(JobSubmitter.java:266)
    at
org.apache.hadoop.mapreduce.JobSubmitter.submitJobInternal(JobSubmitter.java:139)
    at org.apache.hadoop.mapreduce.Job$10.run(Job.java:1290)
    at org.apache.hadoop.mapreduce.Job$10.run(Job.java:1287)
    at java.security.AccessController.doPrivileged(Native Method)
    at javax.security.auth.Subject.doAs(Subject.java:415)
    at
org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1657)
    at org.apache.hadoop.mapreduce.Job.submit(Job.java:1287)
    at org.apache.giraph.job.GiraphJob.run(GiraphJob.java:259)
    at
org.apache.giraph.hive.jython.HiveJythonRunner.run(HiveJythonRunner.java:71)
    at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
    at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:84)
    at
org.apache.giraph.hive.jython.HiveJythonRunner.main(HiveJythonRunner.java:124)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.apache.hadoop.util.RunJar.run(RunJar.java:221)
    at org.apache.hadoop.util.RunJar.main(RunJar.java:136)

Here is the command that I am running:

$HIVE_HOME/bin/hive --service jar
/usr/local/giraph/giraph-hive/target/giraph-hive-1.1.0-jar-with-dependencies.jar
org.apache.giraph.hive.jython.HiveJythonRunner -hiveconf
giraph.SplitMasterWorker=false
/usr/local/giraph/giraph-core/src/test/resources/org/apache/giraph/jython/count-edges.py
/usr/local/giraph/giraph-hive/src/test/resources/org/apache/giraph/jython/count-edges-launcher.py

These are the specific versions that I'm running:

Hadoop: 2.7.1
Hive: 1.2.1
Giraph: 1.1.0

I built Giraph using this command:

mvn -Phadoop_2 -fae -DskipTests clean install

It seems to me that the error is caused by HiveIO being built against
Hadoop1, but I can't find any instructions on how to build it for Hadoop2.
I also saw an email in the mailing list archives where someone had the same
error, but I didn't see a resolution in the thread.  Does anyone have any
thoughts on what I can do to move past this error?

Thanks,

Steve

Mime
View raw message