giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anton Petersson <a.o.peters...@gmail.com>
Subject Re: How can I build giraph 1.1.0-hadoop2 distribution from the source?
Date Thu, 10 Sep 2015 11:09:20 GMT
Dear Roman,

Thanks for your reply.
My application code runs on hadoop 2.4.1, by including the following
dependency.

<dependency>
  <groupId>org.apache.giraph</groupId>
  <artifactId>giraph-core</artifactId>
  <version>1.1.0-hadoop2</version>
</dependency>


I tried to change the dependency to my custom build (such as mvn clean
install -Pyarn -Dhadoop.version=2.4.1 -DskipTests),
but my application code is NOT running on my custom build. Therefore I wish
to know how to build the giraph-core jar (1.1.0-hadoop2) as listed in the
central maven repo.

Best Regards,
Anton

On Thu, Sep 10, 2015 at 2:40 AM, Roman Shaposhnik <roman@shaposhnik.org>
wrote:

> On Tue, Sep 8, 2015 at 2:46 AM, Anton Petersson <a.o.petersson@gmail.com>
> wrote:
> > Hello everyone,
> >
> > //first of all, sorry for reposting this message.
> > //I have mistakenly set the wrong title on the previous message.
> >
> > I am working on the source code of giraph 1.1.0, and I am supposed to
> > customize the code and rebuild the distribution 1.1.0-hadoop2, as the
> > application code is written for that specific distribution.
> >
> > However, I do not know how to build giraph-dist-1.1.0-src.tar.gz from
> > giraph-dist-1.1.0-hadoop2-bin.tar.gz., which are both included in the
> 1.1.0
> > release. I try the following two maven commands,
> >
> >  - mvn -Phadoop_2 -fae -DskipTests clean install
> >  - mvn clean install -Phadoop_2 -Dhadoop.version=2.5.1 -DskipTests
> >
> > but they do not compile into the following distribution.
>
> You need to elaborate here. I do not understand what is your expectation
> vs. what you're seeing.
>
> >   <dependency>
> >     <groupId>org.apache.giraph</groupId>
> >     <artifactId>giraph-core</artifactId>
> >     <version>1.1.0-hadoop2</version>
> >   </dependency>
> >
> > And thus my application code cannot function properly. How can I build
> > giraph 1.1.0-hadoop2 distribution from the source? I will very much
> > appreciate your help!
>
> What is the version of Hadoop you need to run on? Are you planning to
> interface Giraph with any other Hadoop ecosystem projects (like HBase,
> Hive, etc.)?
>
> Thanks,
> Roman.
>

Mime
View raw message