giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kenrick Fernandes <kenrick....@gmail.com>
Subject Input format problems running Giraph 1.1.0 on Twitter dataset
Date Sat, 25 Apr 2015 21:58:54 GMT
Hello,

Im trying to get Giraph to read the Twitter dataset as input for the
SimplePageRankComputation program. The dataset format looks like this:
61578010 61147436
61578037 61147436
61578040 61147436
(vertex id's, with pairs representing edges)

When I run the command with
*-vif org.apache.giraph.io.formats.IntIntNullTextInputFormat*, I get this
error :
*java.lang.IllegalArgumentException: checkClassTypes: vertex index types
not assignable, computation - class org.apache.hadoop.io.LongWritable,
VertexInputFormat - class org.apache.hadoop.io.IntWritable*

So I tried running the command with
*-vif org.apache.giraph.io.formats.LongLongNullTextInputFormat* and I get a
different one:
*java.lang.IllegalArgumentException: checkClassTypes: vertex value types
not assignable, computation - class org.apache.hadoop.io.DoubleWritable,
VertexInputFormat - class org.apache.hadoop.io.LongWritable*

I dont understand why the types in the input show up as different formats
in each error. Also, as far as I could tell, there is no input format for
DoubleDouble. Is there a different way to get the graph into Giraph without
having to write custom input code ? Thoughts would be much appreciated.

-----
Reference Command:
*hadoop jar
giraph-examples-1.1.0-for-hadoop-1.1.2-jar-with-dependencies.jar
org.apache.giraph.GiraphRunner
org.apache.giraph.examples.PageRankComputation -vif
org.apache.giraph.io.formats.LongLongNullTextInputFormat -vip
/user/kenrick/twitter/input -op /user/kenrick/twitter/output -w 30*
-----

Thanks,
Kenrick

Mime
View raw message