giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philipp Nolte <...@daslaboratorium.de>
Subject AW: Compiling Giraph for Hadoop 2.5.x and 2.6.0 -- SASL_PROPS variable error
Date Mon, 15 Dec 2014 00:26:33 GMT
Might have something to do with this Hadoop issue from hadoop 2.3.0

https://issues.apache.org/jira/browse/HADOOP-10451

Quote:

"SaslRpcServer.SASL_PROPS is removed. 
Any use of this variable should be replaced with the following code: 
SaslPropertiesResolver saslPropsResolver = SaslPropertiesResolver.getInstance(conf); 
Map<String, String> sasl_props = saslPropsResolver.getDefaultProperties();“

I don’t know how the graph development works, but why do they „release“ versions that
can not be compiled with standard Hadoop versions (2.5.x has been around for quite a while
now)? Do they even test their releases? Are they really still expect people running old Hadoop
2.0.3?

Sorry

Mime
View raw message