giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Toshio ITO <toshio9....@toshiba.co.jp>
Subject release-1.1.0-RC0 (hadoop_1) unit tests failure
Date Wed, 02 Jul 2014 08:01:15 GMT
Hi all,

I built Giraph release-1.1.0-RC0 tag and ran unit tests. The tests
failed.

Are these failures expected? I feel uncomfortable to see failures in
"Examples".


MY ENVIRONMENT:

- Ubuntu Server 14.04 64bit
- openjdk-7-jdk
- Hadoop 1.2.1 (single node on localhost)

SUMMARY:

- Succeeded to compile. (mvn package -Phadoop_1 -DskipTests)
- Unit tests (with LocalJobRunner) failed at "Rexster I/O Format".
- Unit tests (with a running Hadoop) failed at "Examples".
- Succeeded to run "Shortest Paths Example" in "Quick Start".


DETAIL:

- I ran the following commands.

 $ cd /usr/loca/giraph
 $ git checkout release-1.1.0-RC0
 $ mvn clean package -Phadoop_1 

While running "Rexster I/O Format" tests, it repeated to connect to
ZooKeeper but never succeeded. It kept emitting the following
messages every second.

 14/07/02 11:14:47 INFO zookeeper.ClientCnxn: Opening socket connection to server localhost/127.0.0.1:22182.
Will not attempt to authenticate using SASL (unknown error)
 14/07/02 11:14:47 WARN zookeeper.ClientCnxn: Session 0x146f4da18960002 for server null, unexpected
error, closing socket connection and attempting reconnect
 java.net.ConnectException: Connection refused
         at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
         at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:739)
         at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:350)
         at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1068)

I had to terminate the test by Ctrl-C.


- Then I ran the following commands with Hadoop running.

 $ mvn clean package -Phadoop_1 -Dprop.mapred.job.tracker=localhost:54311

While running "Examples" tests, it stuck at "testBspFail" job. A Map
task was killed because of the following error.

 java.lang.Throwable: Child Error
 	at org.apache.hadoop.mapred.TaskRunner.run(TaskRunner.java:271)
 Caused by: java.io.IOException: Task process exit with nonzero status of 1.
 	at org.apache.hadoop.mapred.TaskRunner.run(TaskRunner.java:258)

After ten minutes, it somehow timed-out and all Map tasks were
killed. The test repeated to connect to ZooKeeper like it did
above. I terminated the test and the Hadoop job.


------------------------------------
Toshio Ito

Mime
View raw message