giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Akila Wajirasena <akila.wajiras...@gmail.com>
Subject Re: Giraph (1.1.0-SNAPSHOT and 1.0.0-RC3) unit tests fail
Date Mon, 30 Jun 2014 10:09:40 GMT
Hi Roman,

I got the same error when running hadoop_2 profile.
According to this [1] the Accumulo version we use in giraph (1.4) is not
compatible with Hadoop 2.
I think this is the issue.

[1]
http://apache-accumulo.1065345.n5.nabble.com/Accumulo-Hadoop-version-compatibility-matrix-tp3893p3894.html

Thanks

Akila

On Mon, Jun 30, 2014 at 2:21 PM, Toshio ITO <toshio9.ito@toshiba.co.jp>
wrote:

> Hi Roman.
>
> I checked out release-1.1.0-RC0 and succeeded to build it.
>
>     $ git checkout release-1.1.0-RC0
>     $ mvn clean
>     $ mvn package -Phadoop_2 -DskipTests
>     ## SUCCESS
>
> However, when I ran the tests with LocalJobRunner, it failed.
>
>     $ mvn clean
>     $ mvn package -Phadoop_2
>
> It passed tests from "Core" and "Examples", but it failed at
> "Accumulo I/O".
>
>
> testAccumuloInputOutput(org.apache.giraph.io.accumulo.TestAccumuloVertexFormat)
>
> The error log contained the following exception
>
>     java.lang.IncompatibleClassChangeError: Found interface
> org.apache.hadoop.mapreduce.JobContext, but class was expected
>
>
> Next I wanted to run the tests with a running Hadoop2 instance, but
> I'm having trouble to set it up (I'm quite new to Hadoop).
>
> Could you show me some example configuration (etc/hadoop/* files) of
> Hadoop 2.2.0 single-node cluster? That would be very helpful.
>
>
>
>
> >
> > On Sun, Jun 29, 2014 at 5:06 PM, Toshio ITO <toshio9.ito@toshiba.co.jp>
> wrote:
> > > Hi Roman.
> > >
> > > Thanks for the reply.
> > >
> > > OK, I'll try hadoop_1 and hadoop_2 with the latest
> > > release-1.1.0-RC0 and report the result.
> >
> > That would be extremely helpful!
> >
> > And speaking of which -- I'd like to remind folks
> > that taking RC0 for a spin would really help
> > at this point. If we ever want to have 1.1.0 out
> > we need the required PMC votes.
> >
> > Thanks,
> > Roman.
> ------------------------------------
> Toshio Ito
>

Mime
View raw message