giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Toshio ITO <toshio9....@toshiba.co.jp>
Subject Giraph (1.1.0-SNAPSHOT and 1.0.0-RC3) unit tests fail
Date Thu, 26 Jun 2014 10:34:25 GMT
Hi all,

I recently tried Giraph.

It compiled fine, but when I did the unit test (i.e. `mvn test`) it
failed.  I did the test several times with different settings. See
below for details.

My question is:

- Is it normal for Giraph? Is the unit test supposed to fail for now?
- If it's not normal, what do you think is wrong?


My environment:

- Ubuntu Server 14.04 64-bit
- Dynamic address by DHCP
- Followed the "Quick Start" guide
  https://giraph.apache.org/quick_start.html
  except I used "localhost" for the node hostname.
-- Installed openjdk-7-jdk, git, maven by apt-get
-- Installed hadoop-0.20.203.0rc1 as instructed


Test settings:

(1) 1.1.0-SNAPSHOT (Commit ID: b218d72cedc52467e691c6002e596e482d8583e4)
    with LocalJobRunner
(2) 1.1.0-SNAPSHOT with the running Hadoop instance
(3) Tag "release-1.0.0-RC3" with LocalJobRunner
(4) Tag "release-1.0.0-RC3" with the running Hadoop instance

Cases (1) and (3) are run by the following commands.

    $ mvn clean
    $ mvn package -Phadoop_0.20.203 -DskipTests
    $ mvn test -Phadoop_0.20.203

Cases (2) and (4) are run by the following commands.

    $ mvn clean
    $ mvn package -Phadoop_0.20.203 -DskipTests
    $ mvn test -Phadoop_0.20.203 -Dprop.mapred.job.tracker=localhost:54311


Test results:

(1) Failed at "Rexster I/O Format". At some point, the test
endlessly tried to connect to ZooKeeper, repeating the following log
messages. I had to terminate the test by Ctrl-C.

    14/06/26 18:10:27 INFO zookeeper.ClientCnxn: Opening socket connection to server localhost/127.0.0.1:22182.
Will not attempt to authenticate using SASL (unknown error)
    14/06/26 18:10:27 WARN zookeeper.ClientCnxn: Session 0x146d76e16750002 for server null,
unexpected error, closing socket connection and attempting reconnect
    java.net.ConnectException: Connection refused
            at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
            at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:739)
            at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:350)
            at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1068)


(2) Failed at "Examples". Hadoop was stuck at "testBspFail"
job. Logs like the following line were printed every 5 seconds for
10 minutes.  After that, the test endlessly tried to connect to
ZooKeeper, just like the case (1). I killed the test process and the
Hadoop job.

    14/06/26 18:40:30 INFO job.JobProgressTracker: Data from 2 workers - Compute superstep
20: 10 out of 10 vertices computed; 6 out of 6 partitions computed; min free memory on worker
1 - 137.42MB, average 149.12MB


(3) Failed at "HBase I/O" in testHBaseInputOutput
(org.apache.giraph.io.hbase.TestHBaseRootMarkerVertextFormat). Before
it reported failure, it blocked for 10 minutes.


(4) Failed at "Core" in testContinue
(org.apache.giraph.io.TestJsonBase64Format) . Hadoop was stuck at
the second "testContinue" job. After 10 minutes, the test went on
and reported the failure. The "testContinue" map task was aborted
with the following error.

    java.io.FileNotFoundException: /tmp/_giraphTests/testContinue/_logs (Is a directory)



Thanks in advance.

------------------------------------
Toshio Ito

Mime
View raw message