giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Agrta Rawat <agrta.ra...@gmail.com>
Subject Re: Edge value types don't match
Date Mon, 07 Apr 2014 05:49:14 GMT
Hi All,

I changed parameter type of my eif edge value and eof edge value to
Writable. But I am getting the same error.

Please suggest what should be done?

Regards,
Agrta Rawat


On Fri, Apr 4, 2014 at 4:58 PM, Agrta Rawat <agrta.rawat@gmail.com> wrote:

> Hi All,
>
> I am running my giraph code on Hadoop CDH-4.5 while the jar, I have built,
> is giraph-1.0.0-for-hadoop-2.0.0-cdh4.1.2-jar-with-dependencies.jar.
>
> When I run the code I get following exception-
>
> Exception in thread "main" java.lang.IllegalArgumentException:
> checkClassTypes: Edge value types don't match, vertex - class
> org.apache.hadoop.io.Text, vertex input format - interface
> org.apache.hadoop.io.Writable
>     at
> org.apache.giraph.job.GiraphConfigurationValidator.verifyVertexInputFormatGenericTypes(GiraphConfigurationValidator.java:245)
>     at
> org.apache.giraph.job.GiraphConfigurationValidator.validateConfiguration(GiraphConfigurationValidator.java:122)
>     at
> org.apache.giraph.utils.ConfigurationUtils.parseArgs(ConfigurationUtils.java:154)
>     at org.apache.giraph.GiraphRunner.run(GiraphRunner.java:74)
>     at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
>     at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:84)
>     at org.apache.giraph.GiraphRunner.main(GiraphRunner.java:124)
>     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>     at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>     at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>     at java.lang.reflect.Method.invoke(Method.java:597)
>     at org.apache.hadoop.util.RunJar.main(RunJar.java:208)
>
> I have tried my code with Text param and Writable param both. But it
> didn't work.
>
> Same code runs perfectly for hadoop-1.0.0 with
> giraph-1.0.0-for-hadoop-1.0.0-with-dependencies.jar.
> Kindly suggest what can be done?
>
> Regards,
> Agrta Rawat
>

Mime
View raw message