giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Agrta Rawat <agrta.ra...@gmail.com>
Subject Re: Running Giraph 1.0.0 for Hadoop 2.0.0
Date Fri, 04 Apr 2014 05:29:56 GMT
Hi,

I have built
giraph-1.0.0-for-hadoop-2.0.0-cdh4.1.2-jar-with-dependencies.jar. When I am
running my code on cluster where CDH-4.5 is installed, I am getting
java.lang.IncompatibleClassChangeError.

Exception in thread "main" java.lang.IncompatibleClassChangeError: Found
interface org.apache.hadoop.mapreduce.JobContext, but class was expected
    at
org.apache.giraph.bsp.BspOutputFormat.checkOutputSpecs(BspOutputFormat.java:43)
    at org.apache.hadoop.mapred.JobClient$2.run(JobClient.java:987)
    at org.apache.hadoop.mapred.JobClient$2.run(JobClient.java:948)
    at java.security.AccessController.doPrivileged(Native Method)
    at javax.security.auth.Subject.doAs(Subject.java:396)
    at
org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1408)
    at
org.apache.hadoop.mapred.JobClient.submitJobInternal(JobClient.java:948)
    at org.apache.hadoop.mapreduce.Job.submit(Job.java:566)
    at org.apache.hadoop.mapreduce.Job.waitForCompletion(Job.java:596)
    at org.apache.giraph.job.GiraphJob.run(GiraphJob.java:237)
    at org.apache.giraph.GiraphRunner.run(GiraphRunner.java:94)
    at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
    at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:84)
    at org.apache.giraph.GiraphRunner.main(GiraphRunner.java:124)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.hadoop.util.RunJar.main(RunJar.java:208)

I have checked that *JobContext is an interface in CDH-4.1.2 and in CDH-4.5
but it is a class in Hadoop-1.0.0*.
So what is the issue? I am nowhere using Hadoop-1.0.0, why am I getting
this error then?
*Is Giraph-1.0.0 not compatible with CDH-4.1.2 or CDH-4.5 for
Hadoop2.0.0?*If yes, Why CDH-4.1.2 profile is given in the pom.xml
file?

I am totally confused. Please help me.

Regards,
Agrta Rawat


On Wed, Apr 2, 2014 at 1:02 PM, Pascal J├Ąger <pascal@pascaljaeger.de> wrote:

>  Hi Argat,
>
>  try it without the =
>
>  I used: mvn install -Phadoop_cdh4.1.2 -DskipTests
>
>  Don't forget to run cdh on java 7, it install java 6 ;)
>
>  Regards
>
>  Pascal
>
>  Am 02.04.2014 um 08:50 schrieb Agrta Rawat <agrta.rawat@gmail.com>:
>
>   Hi Lukas,
>
>  I have installed CDH 4.5 and have built jar for hadoop-cdh4.1.2 profile
> as this is the only profile close to the CDH 4.5 version. But I am getting
> same error.
>  For creating the jar, I used the command -> mvn clean install
> -P=hadoop-cdh4.1.2 inside giraph-core folder.
>
>  Is this error because of hadoop-cdh4.1.2 profile? I also checked for
> hadoop-cdh4.5 profile but could not find it in pom.xml.
>  Please suggest me what should be done
>
>  Regards,
>  Agrta Rawat
>
>
>

Mime
View raw message