giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthew Laird <lai...@sfu.ca>
Subject Re: Giraph & yarn build
Date Mon, 07 Oct 2013 01:04:11 GMT
Further, I let it go and after two hours I see the file:

/giraph-core/target/munged/main/org/apache/giraph/yarn/GiraphYarnTask.java.rej

is now 295GB in size.  I'm not sure what it's stuck doing after applying 
this patch...

Thanks.

On 06/10/13 16:13, Matthew Laird wrote:
> Hello,
>
> I'm trying to build giraph against Hadoop 2.0.5, and I've been 
> browsing the mailing list archives but am still having an issue. I 
> found the previous thread where Eli points to
>
> https://issues.apache.org/jira/browse/GIRAPH-688
>
> I've grabbed the patch and applied it against a clone from git 
> (http://git-wip-us.apache.org/repos/asf/giraph.git, is that the 
> correct place to get the latest trunk?)  Just like the other fellow 
> asking a few months ago, patch complains the patch has been applied 
> before.
>
> Once applied I run the suggested build command:
>
> mvn -U -Phadoop_yarn clean install
>
> It reaches
>
> [INFO] --- munge-maven-plugin:1.0:munge (munge) @ giraph-core ---
>
> And so far it's been sitting there about 20 minutes at this step, in 
> another window I can see it's working hard doing something, but I'm 
> assuming it's stuck doing... I'm not sure what.
>
> Without the patch I receive the same error the other fellow was having 
> about dependancies for hadoop not being satisfied.
>
> Any advice on what might be going on, or is there a better place to 
> get a snapshot that has the needed patches applied? (I see a lot of 
> commits since the original thread)
>
> Thanks!
>


Mime
View raw message