giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Williams <zoo9...@hotmail.com>
Subject RE: FileNotFoundException: File _bsp/_defaultZkManagerDir/job_201308291126_0029/_zkServer does not exist.
Date Thu, 05 Sep 2013 15:27:49 GMT
> great, I need to get a review soon to get the patch in the codebase.
If I can help then let me know.
    Thanks again,
Ken

From: claudio.martella@gmail.com
Date: Thu, 5 Sep 2013 16:50:43 +0200
Subject: Re: FileNotFoundException: File _bsp/_defaultZkManagerDir/job_201308291126_0029/_zkServer
does not exist.
To: user@giraph.apache.org

great, i need to get a review soon to get the patch in the codebase.

On Thu, Sep 5, 2013 at 2:10 PM, Ken Williams <zoo9000@hotmail.com> wrote:





Hi Claudio,
The patch worked !!  :-)
Just to be clear,        I am running Giraph (1.0.0), not git cloned.

         and hadoop 2.0.0-cdh4.1.1
I applied your patch and rebuilt the giraph source code with this command,               
       mvn -Phadoop_2.0.0 clean compile package test install verify

           This built correctly, with no exceptions and no tests failed.   
I then ran the giraph example, which ran successfully with this command
[root@localhost giraph]# hadoop jar /usr/local/giraph/giraph-examples/target/giraph-examples-1.0.0-for-hadoop-2.0.0-
alpha-jar-with-dependencies.jar  org.apache.giraph.GiraphRunner org.apache.giraph.examples.SimpleShortestPathsVertex
 -vif org.apache.giraph.io.formats.JsonLongDoubleFloatDoubleVertexInputFormat  -vip /user/root/input/tiny_graph.txt
  -of org.apache.giraph.io.formats.IdWithValueTextOutputFormat   -op /user/root/output/shortestpaths
-w 1


I then deleted the output                hadoop fs -rm -R  /user/root/output/shortestpaths
I then restarted my HBase daemons, and ran the giraph example again, and it worked successfully
again,

no errors, no exceptions, no tasks failed, and output produced correctly.
Using 'netstat -an | grep 22181' I can see that ZooKeeper is listening on port 22181.


     Thank you very much for your help  :-)
Ken

-- 
    Claudio Martella
    claudio.martella@gmail.com   
 		 	   		  
Mime
View raw message