giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kyle Orlando <kyle.r.orla...@gmail.com>
Subject Question regarding bin/giraph and bin/giraph-env
Date Mon, 29 Jul 2013 21:08:58 GMT
Hello,

I am trying to use the giraph script in $GIRAPH_HOME/bin to run my
giraph code.  However, I cannot seem to get it to work: I keep
getting:

No lib directory, assuming dev environment
No target directory. Build Giraph jar before proceeding.

 After looking at the code, I notice that is runs giraph-env. Within
giraph-env, I see the following:

 if [ -d "$GIRAPH_HOME/lib" ]; then
        for f in $GIRAPH_HOME/lib/*.jar; do
          CLASSPATH=${CLASSPATH}:$f
        done

        for f in $GIRAPH_HOME/giraph*.jar ; do
          if [ -e "$f" ]; then
            JAR=$f
           CLASSPATH=${CLASSPATH}:$f
            break
          fi
        done
else
        echo "No lib directory, assuming dev environment"
        if [ ! -d "$GIRAPH_HOME/target" ]; then
                echo "No target directory. Build Giraph jar before proceeding."
		exit 1
        fi

        CLASSPATH2=`mvn dependency:build-classpath | grep -v "[INFO]"`
	CLASSPATH=$CLASSPATH:$CLASSPATH2

	for f in $GIRAPH_HOME/giraph/target/giraph*.jar; do
          if [ -e "$f" ]; then
            JAR=$f
            break
          fi
	done
fi


This worries me. To obtain my version of giraph, I simply cloned the
git repository and used "mvn -Phadoop_1.0 clean install -DskipTests"
in /usr/local/giraph to build everything.  It appears that this script
sets my GIRAPH_HOME as /usr/local/giraph, but I do not have a
/usr/local/giraph/target directory.  Instead, I have
$GIRAPH_HOME/giraph-core/target, $GIRAPH_HOME/giraph-hbase/target,
etc.  Are these scripts out of date, or have I built my project
incorrectly?

Thanks

-- 
Kyle Orlando
Computer Engineering Major
University of Maryland

Mime
View raw message