giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eli Reisman <apache.mail...@gmail.com>
Subject Re: Hadoop version
Date Wed, 03 Apr 2013 14:03:27 GMT
There's no reason we can't that I know. Try to build generic Giraph for 1.x
hadoop like this:

mvn -Phadoop_1.0 clean verify

next, you might get lucky if the above failed you might try the same but
including a Maven -D option to set the "hadoop.version" property to 1.1.2
(or hadoop-1.1.2, I forget) amd see if THAT builds.

If not, then you'd need to mirror the things in the "regular" hadoop_1.0
Maven profile in the top pom.xml, the giraph-core pom.xml and perhaps the
giraph-examples pom.xml and tweak it from there (dependencies etc.) until
it works. Look back at earlier version extensions (I added 2.0.3 recently)
on our JIRA.



On Wed, Apr 3, 2013 at 4:48 AM, Ahmet Emre Alada─č <emre.aladag@agmlab.com>wrote:

> Hi,
>
> I was wondering if newer Hadoop versions like 1.1.2 will be supported
> soon. Or is it easy to provide support?
>

Mime
View raw message