giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rodrigo zerbini <rodrigo.zerb...@gmail.com>
Subject Newbie problem - I can't run the Shortest Paths Example
Date Wed, 26 Sep 2012 19:01:18 GMT
Hello everybody.

My name is Rodrigo and I'm just starting a scientific initiation on graph
processing systems. I'm trying to run the Shortest Paths Example [
https://cwiki.apache.org/confluence/display/GIRAPH/Shortest+Paths+Example]
taking the following steps in terminal:

hadoop namenode -format
start-all.sh
hadoop-0.20.203.0-jar-with-dependencies.jar
org.apache.giraph.examples.SimpleShortestPathsVertex
shortestPathsInputGraph shortestPathsOutputGraph 0 3

So I got this:

Exception in thread "main" java.io.IOException: Error opening job jar:
giraph-0.2-SNAPSHOT-for-hadoop-0.20.203.0-jar-with-dependencies.jar
at org.apache.hadoop.util.RunJar.main(RunJar.java:90)
Caused by: java.util.zip.ZipException: error in opening zip file
at java.util.zip.ZipFile.open(Native Method)
at java.util.zip.ZipFile.<init>(ZipFile.java:127)
 at java.util.jar.JarFile.<init>(JarFile.java:135)
at java.util.jar.JarFile.<init>(JarFile.java:72)
 at org.apache.hadoop.util.RunJar.main(RunJar.java:88)

Alternatively, I tried to run making this:

hadoop-0.20.203.0-jar-with-dependencies.jar org.apache.giraph.GiraphRunner
org.apache.giraph.examples.SimpleShortestPathsVertex -if
org.apache.giraph.lib.JsonBase64VertexInputFormat -ip
shortestPathsInputGraph -of
org.apache.giraph.lib.JsonBase64VertexOutputFormat -op
shortestPathsOutputGraph -w 3

But I got the same error above.

Am I doing something wrong? I'm using hadoop version 0.2 and there was a
passage in the example saying that, in this case, the class
SimpleShortestPathsVertex does not have a main() method, so I'd have to run
it via the ToolRunner, but what is this tool? How should I proceed with
this?

I'm really stuck here :(
Thanks in advance.

Rodrigo Zerbini
Computer Science student in University of São Paulo

Mime
View raw message