giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Elias Daboussi <>
Subject RE: Newbie problem with Giraph and the ShortestPaths Example
Date Wed, 08 Aug 2012 08:38:15 GMT

I don't know what happenned to my message,every comma has been replaced by =C2, so I attached
a normal txt version to this post.

Subject: Newbie problem with Giraph and the ShortestPaths Example
Date: Wed, 8 Aug 2012 08:30:56 +0000

Hello everyone,
I am having some trouble understanding the shortest path example, and some basic things of
Giraph :
I am currently using the giraph-0.1-with-dependencies jar, compiled from Maven, and Hadoop

When I launch the example, with the exact same input as given in the example, with 1 worker,
here is what I have as a result :


If I choose a source ID of, for example, 3, I get (still with one worker) :


I see here that the node 3 has a 0 value on it, and thus I understand that its the starting
point. So everything is fine. 
I tried to add more edges and do the following graph :


I tried to start the job from node 2, but I didnt get any output, my job gets stuck…what
am I doing wrong? I feel like when I add edges, it always gets stuck.Is there a problem in
the way I add jobs? Or in my graph?

Also I was wondering how to add my own examples : what should I do if I want to add an example
Can I do something like that :
hadoop jar giraph-0.1-jar-with-dependencies.jar myexampleclass <args>
And if I do so, where should I place my myexampleclass class? 
Another newbie question : The shortestpaths example has a main method, but some others don't.
I understood that I need to use the GiraphRunner jar, but I don't really know how to use it
: two arguments are needed : the number of workers, and the input format, then the other arguments.Can
someone tell me how I should do, for example, to run the Shortestpaths example, with the 0.2
version of Giraph (this version does not have a main method)?

Last question, why can't I use the bin/giraph command? (and what is this command made for?
Is it for running a giraph job jar? or just to run the giraph jar?) whatever I do, it says
"can't find the giraph jar"….
Thanks a lot! I hope my questions were not too silly...
I hope I was clear enough, forgive my english, I am French :) 		 	   		   		 	   		  
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message