giraph-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Etienne Dumoulin <>
Subject java.lang.RuntimeException [...] msgMap did not exist [...]
Date Fri, 13 Apr 2012 10:35:15 GMT
Hi Guys,

I tried out giraph yesterday and I have an issue to run the shortest path

I am working on a toy heterogeneous cluster of 3 datanodes and 1 namenode,
jobtracker, with hadoop
One of the datanode is a small server quad-core 16 GB ram, the others are
small PC 1 core 1GB ram, same OS: ubuntu-server 10.04.

I run on a first issue with the 0.1 version, the same described here:
Before I found the patch I tried different configurations:
It works on a standalone environment, with the namenode and the server,
with the namenode and the two small PC.
It does not work either with the entire cluster, or with one small PC and
the server as datanode.

Then I downloaded today the svn version, no luck, it has the same behaviour
than the 0.1 version (go till 100% then go back to 0%) but not the same
info logs.
Bellow the svn version console log, "nantes" is the name of the big
datanode, "rennes" the namenode/jobtracker:

hadoop@rennes:~/test$ hadoop jar
shortestPathsInputGraph shortestPathsOutputGraph 0 3
12/04/13 10:05:58 INFO mapred.JobClient: Running job: job_201204121836_0003
12/04/13 10:05:59 INFO mapred.JobClient:  map 0% reduce 0%
12/04/13 10:06:18 INFO mapred.JobClient:  map 25% reduce 0%
12/04/13 10:08:55 INFO mapred.JobClient:  map 100% reduce 0%
12/04/13 10:21:28 INFO mapred.JobClient:  map 75% reduce 0%
12/04/13 10:21:33 INFO mapred.JobClient: Task Id :
attempt_201204121836_0003_m_000002_0, Status : FAILED
Task attempt_201204121836_0003_m_000002_0 failed to report status for 600
seconds. Killing!
12/04/13 10:23:57 INFO mapred.JobClient: Task Id :
attempt_201204121836_0003_m_000001_0, Status : FAILED
java.lang.RuntimeException: sendMessage: msgMap did not exist for
nantes:30002 for vertex 2
        at org.apache.giraph.graph.BasicVertex.sendMsg(
        at org.apache.hadoop.mapred.MapTask.runNewMapper(
        at org.apache.hadoop.mapred.Child$
        at Method)
        at org.apache.hadoop.mapred.Child.main(

Task attempt_201204121836_0003_m_000001_0 failed to report status for 601
seconds. Killing!
12/04/13 10:23:58 INFO mapred.JobClient:  map 50% reduce 0%
12/04/13 10:24:01 INFO mapred.JobClient:  map 25% reduce 0%
12/04/13 10:24:06 INFO mapred.JobClient: Task Id :
attempt_201204121836_0003_m_000003_0, Status : FAILED
Task attempt_201204121836_0003_m_000003_0 failed to report status for 602
seconds. Killing!

I attached the hadoop logs for "rennes" namenode and jobtraker and for
"nantes" the big datanode.

Is someone already got this error/found a fix?

Thanks for your time,


View raw message