giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Balajik (JIRA)" <j...@apache.org>
Subject [jira] [Created] (GIRAPH-1102) What is the contemptible giraph version for apache hadoop 2.7.2
Date Thu, 04 Aug 2016 13:44:21 GMT
Balajik created GIRAPH-1102:
-------------------------------

             Summary: What is the contemptible giraph version for apache hadoop 2.7.2
                 Key: GIRAPH-1102
                 URL: https://issues.apache.org/jira/browse/GIRAPH-1102
             Project: Giraph
          Issue Type: Bug
          Components: bsp, documentation, examples
    Affects Versions: 1.1.0
            Reporter: Balajik


May i know what is the compatible version of girapgh to run on apache hadoop 2.7.2.

AS the website has no proper information and we are not able to run basic example.

with the following errors

Error type 1.
Exception in thread "main" java.lang.IncompatibleClassChangeError: Found interface org.apache.hadoop.mapreduce.JobContext,
but class was expected
        at org.apache.giraph.bsp.BspOutputFormat.checkOutputSpecs(BspOutputFormat.java:43)
        at org.apache.hadoop.mapreduce.JobSubmitter.checkSpecs(JobSubmitter.java:266)
        at org.apache.hadoop.mapreduce.JobSubmitter.submitJobInternal(JobSubmitter.java:139


Error type 2:
Exception in thread "main" java.lang.IllegalArgumentException: Wrong FS: hdfs://XXX.XX.XXX.XX:XXXX/mapred/hydhdfs/tiny_graph.txt,
expected: hdfs://mycluster
        at org.apache.hadoop.fs.FileSystem.checkPath(FileSystem.java:646)
        at org.apache.hadoop.hdfs.DistributedFileSystem.getPathName(DistributedFileSystem.java:194)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message