giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jialin LIu (JIRA)" <j...@apache.org>
Subject [jira] [Created] (GIRAPH-1038) mvn -Phadoop_2 -Dhadoop.version=2.7.1 compile not work for OS X
Date Sat, 24 Oct 2015 14:45:27 GMT
Jialin LIu created GIRAPH-1038:
----------------------------------

             Summary: mvn -Phadoop_2 -Dhadoop.version=2.7.1 compile not work for OS X
                 Key: GIRAPH-1038
                 URL: https://issues.apache.org/jira/browse/GIRAPH-1038
             Project: Giraph
          Issue Type: Bug
          Components: build
    Affects Versions: 1.2.0-SNAPSHOT
         Environment: Mac OS X 10.11.1(I think it is OS X not the subversion)
            Reporter: Jialin LIu


When using Ubuntu 14.04 LTS, I set up Giraph 1.2 + Hadoop 2.7.1. After package I can write
code in giraph-examples/src and then mvn -Phadoop_2 -Dhadoop.version=2.7.1 compile it's done
and run hadoop all went well. But when I tried to use Giraph 1.2 + Hadoop 2.7.1 on Mac OS
X (10.11.1), the mvn compile in the giraph-examples/ worked but when I tried to run bin/hadoop
... as taught in the tutorial, it failed with the following:

Exception in thread "main" java.lang.IncompatibleClassChangeError: Found interface org.apache.hadoop.mapreduce.JobContext,
but class was expected
	at org.apache.giraph.bsp.BspOutputFormat.checkOutputSpecs(BspOutputFormat.java:43)
	at org.apache.hadoop.mapreduce.JobSubmitter.checkSpecs(JobSubmitter.java:266)
	at org.apache.hadoop.mapreduce.JobSubmitter.submitJobInternal(JobSubmitter.java:139)
	at org.apache.hadoop.mapreduce.Job$10.run(Job.java:1290)
	at org.apache.hadoop.mapreduce.Job$10.run(Job.java:1287)
	at java.security.AccessController.doPrivileged(Native Method)
	at javax.security.auth.Subject.doAs(Subject.java:422)
	at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1657)
	at org.apache.hadoop.mapreduce.Job.submit(Job.java:1287)
	at org.apache.giraph.job.GiraphJob.run(GiraphJob.java:259)
	at org.apache.giraph.GiraphRunner.run(GiraphRunner.java:94)
	at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
	at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:84)
	at org.apache.giraph.GiraphRunner.main(GiraphRunner.java:124)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:497)
	at org.apache.hadoop.util.RunJar.run(RunJar.java:221)
	at org.apache.hadoop.util.RunJar.main(RunJar.java:136)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message