giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roman Shaposhnik (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GIRAPH-626) Remove use of deprecated API's in giraph-core
Date Mon, 10 Feb 2014 03:50:19 GMT

    [ https://issues.apache.org/jira/browse/GIRAPH-626?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13896189#comment-13896189
] 

Roman Shaposhnik commented on GIRAPH-626:
-----------------------------------------

Pushing out of 1.1.0 release

> Remove use of deprecated API's in giraph-core
> ---------------------------------------------
>
>                 Key: GIRAPH-626
>                 URL: https://issues.apache.org/jira/browse/GIRAPH-626
>             Project: Giraph
>          Issue Type: Bug
>          Components: build, graph
>    Affects Versions: 0.1.0, 1.0.0
>         Environment: Ubuntu 12.04, Hadoop 1.1.1, Giraph 1.0RC0
>            Reporter: Lewis John McGibbney
>
> When I compile & test the new 1.0 RC0 (great work BTW), I get the following WARNINGs
within Maven. 
> {code}
> [WARNING] /home/law/Downloads/asf/giraph/giraph/giraph-core/target/munged/main/org/apache/giraph/utils/UnsafeByteArrayInputStream.java:[34,32]
sun.misc.Unsafe is internal proprietary API and may be removed in a future release
> [WARNING] /home/law/Downloads/asf/giraph/giraph/giraph-core/target/munged/main/org/apache/giraph/utils/UnsafeByteArrayInputStream.java:[37,29]
sun.misc.Unsafe is internal proprietary API and may be removed in a future release
> [WARNING] /home/law/Downloads/asf/giraph/giraph/giraph-core/target/munged/main/org/apache/giraph/utils/UnsafeByteArrayInputStream.java:[39,25]
sun.misc.Unsafe is internal proprietary API and may be removed in a future release
> [WARNING] /home/law/Downloads/asf/giraph/giraph/giraph-core/target/munged/main/org/apache/giraph/utils/UnsafeByteArrayOutputStream.java:[33,29]
sun.misc.Unsafe is internal proprietary API and may be removed in a future release
> [WARNING] /home/law/Downloads/asf/giraph/giraph/giraph-core/target/munged/main/org/apache/giraph/utils/UnsafeByteArrayOutputStream.java:[35,25]
sun.misc.Unsafe is internal proprietary API and may be removed in a future release
> [WARNING] /home/law/Downloads/asf/giraph/giraph/giraph-core/target/munged/main/org/apache/giraph/utils/UnsafeByteArrayOutputStream.java:[66,32]
sun.misc.Unsafe is internal proprietary API and may be removed in a future release
> [WARNING] /home/law/Downloads/asf/giraph/giraph/giraph-core/target/munged/main/org/apache/giraph/comm/netty/handler/SaslServerHandler.java:
Some input files use or override a deprecated API.
> [WARNING] /home/law/Downloads/asf/giraph/giraph/giraph-core/target/munged/main/org/apache/giraph/comm/netty/handler/SaslServerHandler.java:
Recompile with -Xlint:deprecation for details.
> [WARNING] /home/law/Downloads/asf/giraph/giraph/giraph-core/target/munged/main/org/apache/giraph/io/superstep_output/MultiThreadedSuperstepOutput.java:
Some input files use unchecked or unsafe operations.
> [WARNING] /home/law/Downloads/asf/giraph/giraph/giraph-core/target/munged/main/org/apache/giraph/io/superstep_output/MultiThreadedSuperstepOutput.java:
Recompile with -Xlint:unchecked for details.
> {code}
> I've not looked in to this AT ALL, but I thought I would log it and maybe get the GSoC
student (if we get in) to submit a patch to upgrade the offending API usage to fix it. I see
this as potentially low hanging fruit for people wanting to contribute to Giraph.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message