giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexandre Fonseca (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GIRAPH-813) Compilation problems with Hadoop 2.2.0
Date Mon, 09 Dec 2013 11:49:08 GMT

    [ https://issues.apache.org/jira/browse/GIRAPH-813?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13843088#comment-13843088
] 

Alexandre Fonseca commented on GIRAPH-813:
------------------------------------------

That probably means it can't find some class. Check the error logs ($HADOOP_HOME/logs/userlogs/<app
id> by default) for the application attempt. You'll probably see something like "Unable
to find class for GiraphApplicationMaster" or "org.apache.hadoop.mapred.<something>".
Make sure you have HADOOP_MAPRED_HOME (if it isn't, change and don't forget to restart the
nodemanager and resourcemanager) pointing to your hadoop installation, copy the examples jar
to your current directory and add the following to your launch command: {code}-yj giraph-examples-1.1.0-SNAPSHOT-for-
hadoop-2.2.0-jar-with-dependencies.jar{code}

Since you seem to be hitting all the same obstacles I did, I'll point you to my mail on the
user mailing list with all the steps, commands and related issues: http://mail-archives.apache.org/mod_mbox/giraph-user/201312.mbox/%3C1728318.aUba3J2PDU%40chronos7%3E

> Compilation problems with Hadoop 2.2.0
> --------------------------------------
>
>                 Key: GIRAPH-813
>                 URL: https://issues.apache.org/jira/browse/GIRAPH-813
>             Project: Giraph
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 1.1.0
>         Environment: >hadoop version
> Hadoop 2.2.0
> Subversion https://svn.apache.org/repos/asf/hadoop/common -r 1529768
> Compiled by hortonmu on 2013-10-07T06:28Z
> Compiled with protoc 2.5.0
> From source with checksum 79e53ce7994d1628b240f09af91e1af4
>            Reporter: Placek
>
> Running the code:
> -----------------------
> git clone git://git.apache.org/giraph.git snapshot_from_git
> cd snapshot_from_git
> mvn -Phadoop_yarn -Dhadoop.version=2.2.0 clean package -DskipTests
> Produces:
> -------------
> Cloning into 'snaphot_from_git'...
> remote: Counting objects: 16809, done.
> remote: Compressing objects: 100% (7476/7476), done.
> remote: Total 16809 (delta 9496), reused 11044 (delta 6199)
> Receiving objects: 100% (16809/16809), 21.95 MiB | 4.39 MiB/s, done.
> Resolving deltas: 100% (9496/9496), done.
> [INFO] Scanning for projects...
> [INFO] ------------------------------------------------------------------------
> [INFO] Reactor Build Order:
> [INFO] 
> [INFO] Apache Giraph Parent
> [INFO] Apache Giraph Core
> [INFO] Apache Giraph Examples
> [INFO] Apache Giraph Distribution
> [INFO]                                                                         
> [INFO] ------------------------------------------------------------------------
> [INFO] Building Apache Giraph Parent 1.1.0-SNAPSHOT
> [INFO] ------------------------------------------------------------------------
> [INFO] 
> [INFO] --- maven-clean-plugin:2.3:clean (default-clean) @ giraph-parent ---
> [INFO] 
> [INFO] --- mavanagaiata:0.5.0:branch (git-commit) @ giraph-parent ---
> [INFO] 
> [INFO] --- mavanagaiata:0.5.0:commit (git-commit) @ giraph-parent ---
> [INFO] 
> [INFO] --- maven-enforcer-plugin:1.2:enforce (default) @ giraph-parent ---
> [INFO] Skipping Rule Enforcement.
> [INFO] 
> [INFO] --- maven-dependency-versions-check-plugin:2.0.2:check (default) @ giraph-parent
---
> [INFO] Checking dependency versions
> [ERROR] Found a problem with the dependency commons-httpclient:commons-httpclient
>   Resolved version is 3.0.1
>   Version 3.1 was expected by artifact: org.apache.hadoop:hadoop-common
> [ERROR] Found a problem with the dependency commons-logging:commons-logging
>   Resolved version is 1.0.4
>   Version 1.1.1 was expected by artifact: org.apache.hadoop:hadoop-common
> [ERROR] Found a problem with the dependency io.netty:netty
>   Resolved version is 3.5.3.Final
>   Version 3.6.2.Final was expected by artifacts: org.apache.hadoop:hadoop-mapreduce-client-common,
org.apache.hadoop:hadoop-mapreduce-client-core, org.apache.hadoop:hadoop-yarn-common, org.apache.hadoop:hadoop-yarn-server-common,
org.apache.hadoop:hadoop-yarn-server-nodemanager, org.apache.hadoop:hadoop-yarn-server-resourcemanager,
org.apache.hadoop:hadoop-yarn-server-tests:test-jar
> [ERROR] Found a problem with the dependency org.apache.zookeeper:zookeeper
>   Resolved version is 3.3.3
>   Version 3.4.5 was expected by artifacts: org.apache.hadoop:hadoop-common, org.apache.hadoop:hadoop-mapreduce-client-common,
org.apache.hadoop:hadoop-yarn-server-common, org.apache.hadoop:hadoop-yarn-server-nodemanager,
org.apache.hadoop:hadoop-yarn-server-resourcemanager, org.apache.hadoop:hadoop-yarn-server-tests:test-jar
> [INFO] ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO] 
> [INFO] Apache Giraph Parent .............................. FAILURE [14.980s]
> [INFO] Apache Giraph Core ................................ SKIPPED
> [INFO] Apache Giraph Examples ............................ SKIPPED
> [INFO] Apache Giraph Distribution ........................ SKIPPED
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 16.684s
> [INFO] Finished at: Mon Dec 09 04:42:08 CET 2013
> [INFO] Final Memory: 23M/334M
> [INFO] ------------------------------------------------------------------------
> [ERROR] Failed to execute goal com.ning.maven.plugins:maven-dependency-versions-check-plugin:2.0.2:check
(default) on project giraph-parent: Found dependency version conflicts -> [Help 1]
> [ERROR] 
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR] 
> [ERROR] For more information about the errors and possible solutions, please read the
following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message