giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexandre Fonseca (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GIRAPH-804) Compilation problems with Hadoop 0.23
Date Sat, 07 Dec 2013 20:20:35 GMT

    [ https://issues.apache.org/jira/browse/GIRAPH-804?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13842323#comment-13842323
] 

Alexandre Fonseca commented on GIRAPH-804:
------------------------------------------

I also had the same errors as you with an Hadoop 2.2.0 compilation target. By reverting to
commit [357c186584ddce07853db125c5de09ccc144e5d3|https://git-wip-us.apache.org/repos/asf?p=giraph.git;a=commit;h=357c186584ddce07853db125c5de09ccc144e5d3],
I was able to compile again. Problems seem to have been introduced by GIRAPH-798.

> Compilation problems with Hadoop 0.23
> -------------------------------------
>
>                 Key: GIRAPH-804
>                 URL: https://issues.apache.org/jira/browse/GIRAPH-804
>             Project: Giraph
>          Issue Type: Bug
>            Reporter: Gianmarco De Francisci Morales
>
> When checking out trunk and compiling the hadoop_0.23 profile, the compilation fails
because of some dependency problem:
> {code}
> [ERROR] Found a problem with the dependency commons-httpclient:commons-httpclient
>   Resolved version is 3.0.1
>   Version 3.1 was expected by artifact: org.apache.hadoop:hadoop-common
> [ERROR] Found a problem with the dependency commons-logging:commons-logging
>   Resolved version is 1.0.4
>   Version 1.1.1 was expected by artifacts: org.apache.hadoop:hadoop-common, org.apache.hadoop:hadoop-mapreduce-client-common,
org.apache.hadoop:hadoop-mapreduce-client-core
> [ERROR] Found a problem with the dependency org.apache.zookeeper:zookeeper
>   Resolved version is 3.3.3
>   Version 3.4.2 was expected by artifact: org.apache.hadoop:hadoop-mapreduce-client-common
> [ERROR] Found a problem with the dependency org.jboss.netty:netty
>   Resolved version is 3.2.3.Final
>   Version 3.2.3.Final was expected by artifacts: org.apache.hadoop:hadoop-mapreduce-client-common,
org.apache.hadoop:hadoop-mapreduce-client-core
>   Version 3.2.4.Final was expected by artifact: org.apache.hadoop:hadoop-common
> {code}



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message