giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Purtell (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GIRAPH-712) Fixup to use NIOServerCnxnFactory after ZOOKEEPER-733 (zk >= 3.4.0)
Date Tue, 09 Jul 2013 02:53:48 GMT

    [ https://issues.apache.org/jira/browse/GIRAPH-712?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13702819#comment-13702819
] 

Andrew Purtell commented on GIRAPH-712:
---------------------------------------

bq. What's the benefit of upgrading ZooKeeper?

Two of the big ones:

- SASL/Kerberos authentication for use in conjunction with ZooKeeper ACLs

- Multi update: http://tdunning.blogspot.com/2011/06/tour-of-multi-update-for-zookeeper.html


There have been five point releases since 3.4.0 that have resolved issues with those, see:
http://zookeeper.apache.org/doc/r3.4.5/releasenotes.html
                
> Fixup to use NIOServerCnxnFactory after ZOOKEEPER-733 (zk >= 3.4.0)
> -------------------------------------------------------------------
>
>                 Key: GIRAPH-712
>                 URL: https://issues.apache.org/jira/browse/GIRAPH-712
>             Project: Giraph
>          Issue Type: Improvement
>            Reporter: Andrew Purtell
>         Attachments: 712.patch
>
>
> If/when you would like to upgrade to a ZooKeeper >= 3.4.0, a fixup to InternalVertexRunner
is required for changes introduced by ZOOKEEPER-733.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message