giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maja Kabiljo (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GIRAPH-536) Clean up configuration options
Date Wed, 03 Apr 2013 03:43:15 GMT

    [ https://issues.apache.org/jira/browse/GIRAPH-536?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13620572#comment-13620572
] 

Maja Kabiljo commented on GIRAPH-536:
-------------------------------------

I would add 'master' to NUM_ZK_INPUT_SPLIT_THREADS, and I don't see that you solved 4) from
the task.
                
> Clean up configuration options
> ------------------------------
>
>                 Key: GIRAPH-536
>                 URL: https://issues.apache.org/jira/browse/GIRAPH-536
>             Project: Giraph
>          Issue Type: Bug
>    Affects Versions: 0.2.0
>            Reporter: Alessandro Presta
>            Assignee: Alessandro Presta
>         Attachments: GIRAPH-536.patch
>
>
> Option names are all over the place, and I think they should be rationalized before we
cut the 0.2 release.
> Some examples:
> 1) Options that don't start with "giraph.*", like "partition.*".
> 2) Ambiguous naming: "giraph.numInputSplitsThreads" refers to worker input threads, "giraph.inputSplitThreadCount"
refers to threads used by the master to write splits to ZooKeeper.
> 3) Some options are defined in GiraphConstants, some other ones in the classes that use
them. We can find all of them by searching for "static final String".
> 4) "giraph.zKForceSync" and "giraph.ZkSkipAcl" use "yes"/"no" instead of true/false,
just because they are later used to write ZK configuration (which requires "yes"/"no"). I
think we should stick to true/false since these are Giraph options regardless.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message