giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alessandro Presta (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (GIRAPH-536) Clean up configuration options
Date Tue, 02 Apr 2013 23:35:15 GMT

     [ https://issues.apache.org/jira/browse/GIRAPH-536?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alessandro Presta updated GIRAPH-536:
-------------------------------------

    Attachment: GIRAPH-536.patch
    
> Clean up configuration options
> ------------------------------
>
>                 Key: GIRAPH-536
>                 URL: https://issues.apache.org/jira/browse/GIRAPH-536
>             Project: Giraph
>          Issue Type: Bug
>    Affects Versions: 0.2.0
>            Reporter: Alessandro Presta
>         Attachments: GIRAPH-536.patch
>
>
> Option names are all over the place, and I think they should be rationalized before we
cut the 0.2 release.
> Some examples:
> 1) Options that don't start with "giraph.*", like "partition.*".
> 2) Ambiguous naming: "giraph.numInputSplitsThreads" refers to worker input threads, "giraph.inputSplitThreadCount"
refers to threads used by the master to write splits to ZooKeeper.
> 3) Some options are defined in GiraphConstants, some other ones in the classes that use
them. We can find all of them by searching for "static final String".
> 4) "giraph.zKForceSync" and "giraph.ZkSkipAcl" use "yes"/"no" instead of true/false,
just because they are later used to write ZK configuration (which requires "yes"/"no"). I
think we should stick to true/false since these are Giraph options regardless.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message