giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eli Reisman (JIRA)" <>
Subject [jira] [Commented] (GIRAPH-536) Clean up configuration options
Date Fri, 05 Apr 2013 06:00:24 GMT


Eli Reisman commented on GIRAPH-536:

This has waited a long time. Great one! Absolutely needed for the release. Everyone gets confused
about this stuff, and it leaves a frustrated impression before folks have the chance to really
see what Giraph can do for them.

These details matter! Thanks for getting to this!!!
> Clean up configuration options
> ------------------------------
>                 Key: GIRAPH-536
>                 URL:
>             Project: Giraph
>          Issue Type: Bug
>    Affects Versions: 0.2.0
>            Reporter: Alessandro Presta
>            Assignee: Alessandro Presta
>         Attachments: GIRAPH-536.patch, GIRAPH-536.patch, GIRAPH-536.patch
> Option names are all over the place, and I think they should be rationalized before we
cut the 0.2 release.
> Some examples:
> 1) Options that don't start with "giraph.*", like "partition.*".
> 2) Ambiguous naming: "giraph.numInputSplitsThreads" refers to worker input threads, "giraph.inputSplitThreadCount"
refers to threads used by the master to write splits to ZooKeeper.
> 3) Some options are defined in GiraphConstants, some other ones in the classes that use
them. We can find all of them by searching for "static final String".
> 4) "giraph.zKForceSync" and "giraph.ZkSkipAcl" use "yes"/"no" instead of true/false,
just because they are later used to write ZK configuration (which requires "yes"/"no"). I
think we should stick to true/false since these are Giraph options regardless.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message