giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alessandro Presta" <alessan...@fb.com>
Subject Re: Review Request: In memory testing framework added
Date Tue, 26 Mar 2013 21:59:06 GMT


> On March 20, 2013, 10:56 p.m., Alessandro Presta wrote:
> > giraph-core/src/main/java/org/apache/giraph/utils/InMemoryVertexInput.java, line
129
> > <https://reviews.apache.org/r/10052/diff/1/?file=272631#file272631line129>
> >
> >     I would call this "getEdges", maybe "createEdges". Also, looks like it could
be converted to a static method.
> 
> Veselin Stoyanov wrote:
>     I changed the name, but if I make it static, I can't use the generic types.

Can't you make it a generic method?


> On March 20, 2013, 10:56 p.m., Alessandro Presta wrote:
> > giraph-core/src/main/java/org/apache/giraph/utils/InMemoryVertexInput.java, line
170
> > <https://reviews.apache.org/r/10052/diff/1/?file=272631#file272631line170>
> >
> >     Assigning the format's conf from the reader doesn't feel right.
> >     You can instead make the format implement ImmutableClassesGiraphConfigurable,
so that Giraph will provide it with the conf upon instantiation.
> 
> Veselin Stoyanov wrote:
>     I was going by the way that this is done in io.formats.TextVertexInputFormat (line
101). I can change it if you think it's better.

Yes, I think it's better. A member class setting a field of the enclosing class seems error-prone.


- Alessandro


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/10052/#review18177
-----------------------------------------------------------


On March 26, 2013, 9:25 p.m., Veselin Stoyanov wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/10052/
> -----------------------------------------------------------
> 
> (Updated March 26, 2013, 9:25 p.m.)
> 
> 
> Review request for giraph.
> 
> 
> Description
> -------
> 
> A framework for running small test graphs in memory.
> 
> 
> Diffs
> -----
> 
>   giraph-core/src/main/java/org/apache/giraph/utils/InMemoryEdgeInput.java PRE-CREATION

>   giraph-core/src/main/java/org/apache/giraph/utils/InMemoryVertexInput.java PRE-CREATION

>   giraph-core/src/main/java/org/apache/giraph/utils/InMemoryVertexOutput.java PRE-CREATION

>   giraph-core/src/main/java/org/apache/giraph/utils/InternalVertexRunner.java 7e0b955998a5f1890912819fa2ca74fbbf46fedd

>   giraph-core/src/main/java/org/apache/giraph/utils/TestGraph.java PRE-CREATION 
>   giraph-examples/src/test/java/org/apache/giraph/examples/ConnectedComponentsVertexTestInMemory.java
PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/10052/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Veselin Stoyanov
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message