giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nitay Joffe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GIRAPH-472) Refactor MapFunctions enum to be more general
Date Thu, 17 Jan 2013 23:40:13 GMT

    [ https://issues.apache.org/jira/browse/GIRAPH-472?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13556756#comment-13556756
] 

Nitay Joffe commented on GIRAPH-472:
------------------------------------

Commit separately sounds good, always nice to have small units in commits... makes things
easier to debug.
                
> Refactor MapFunctions enum to be more general
> ---------------------------------------------
>
>                 Key: GIRAPH-472
>                 URL: https://issues.apache.org/jira/browse/GIRAPH-472
>             Project: Giraph
>          Issue Type: Improvement
>          Components: graph
>    Affects Versions: 0.2.0
>            Reporter: Eli Reisman
>            Assignee: Eli Reisman
>            Priority: Minor
>         Attachments: GIRAPH-472.patch
>
>
> In preparation for refactors like GIRAPH-469, lets make some of the boilerplate code
in and around GraphMapper more general and behavior-oriented and less Hadoopy.
> To this end, lets make the MapFunctions enum into something more general we can make
use of in multiple driver implementations including those that are not based on MRv1 or GraphMapper.
> This passes 'mvn verify' on today's trunk but the giraph-accumulo part of the build fails.
After grepping the accumulo code, I don't see anything affected by MapFunctions so I'm assuming
this is an unrelated matter. ;)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message