geronimo-xbean-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Esther Jesurum (JIRA)" <j...@apache.org>
Subject [jira] Updated: (XBEAN-147) Invalid synthesized namespace prefix for ACORD xsd
Date Tue, 13 Apr 2010 17:59:03 GMT

     [ https://issues.apache.org/jira/browse/XBEAN-147?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Esther Jesurum updated XBEAN-147:
---------------------------------

    Attachment: AMI_1_0_0_ACORD_1_0_Simplified.xsd

To reproduce, generate for the attached schema using defaults.  Create an instance of ACORD
and get the text.  Can also see the bad behavior by creating sample XML using SampleXMLUtil.createSampleForType.

> Invalid synthesized namespace prefix for ACORD xsd
> --------------------------------------------------
>
>                 Key: XBEAN-147
>                 URL: https://issues.apache.org/jira/browse/XBEAN-147
>             Project: XBean
>          Issue Type: Bug
>    Affects Versions: 2.0
>         Environment: Windows XP
>            Reporter: Esther Jesurum
>         Attachments: AMI_1_0_0_ACORD_1_0_Simplified.xsd
>
>
> I have an issue where the synthesized namespace prefix results in invalid XML.  In the
XSD, the target namespace is: http://www.ACORD.org/standards/PC_Surety/ACORD1.0.0/xml/ (I
got this from ACORD) and in the saved XML, if I don't explicitly set suggested prefixes on
the XmlOptions, I am getting "x/" as the namespace prefix (that trailing '/' makes the XML
invalid).

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message