geronimo-xbean-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacek Laskowski <>
Subject Re: xbean 3.7-snapshot deployed
Date Sun, 31 Jan 2010 13:48:54 GMT
2010/1/30 Jacek Laskowski <>:

> Just to let you know that the latest (01/30) xbean has just been
> deployed to the snapshot repo.

...and I don't think it was a wise move. I think it contains a NCDF
issue with org.objectweb.asm package. I'm on MacOS with Java 6:

devmac:xbean-finder-shaded jacek$ java -version
java version "1.6.0_17"
Java(TM) SE Runtime Environment (build 1.6.0_17-b04-248-10M3025)
Java HotSpot(TM) 64-Bit Server VM (build 14.3-b01-101, mixed mode)
devmac:xbean-finder-shaded jacek$ uname -a
Darwin devmac.local 10.2.0 Darwin Kernel Version 10.2.0: Tue Nov  3
10:37:10 PST 2009; root:xnu-1486.2.11~1/RELEASE_I386 i386

and the more I look into it the more I'm convinced to think there's a
bug with shading on this platform.

I created a simple app:

package pl.jaceklaskowski.mavenproject1;

import javax.jws.WebService;
import org.apache.xbean.finder.ClassFinder;

public class NewClass {
  public static void main(String[] args) throws Exception {
    URL[] urls = new URL[] { File.createTempFile("aaa", "bbb").toURI().toURL()};
    ClassFinder finder = new ClassFinder(new URLClassLoader(urls));

with the following pom.xml:

<project xmlns=""

When I run it with the current configuration, i.e. with
xbean-finder-shaded-3.7-SNAPSHOT.jar which is replaced right after the
shading process it blows up with:

[Loaded org.apache.xbean.finder.ClassFinder from
Exception in thread "main" java.lang.NoClassDefFoundError:
        at pl.jaceklaskowski.mavenproject1.NewClass.main(
Caused by: java.lang.ClassNotFoundException: org.apache.xbean.asm.ClassVisitor
        at Method)
        at java.lang.ClassLoader.loadClass(
        at sun.misc.Launcher$AppClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        at java.lang.ClassLoader.loadClassInternal(
        ... 1 more

I run the sample with -verbose:class to see where the ClassVisitor
class comes from - you can see the result a line above the exception.

When I change the pom.xml with:


and do


in the xbean-finder-shaded's pom.xml it works fine.

Anybody can shed some light on it? I'm stuck with the change in xbean
for asm parsing of generic classes. I'm looking into it right now
(which makes 2-day hard thinking on it and I feel my brain's melting
down). Help!


Jacek Laskowski
Notatnik Projektanta Java EE -
p.s. Szukam speca/firmy od grafiki/CSS/HTML

View raw message